WordPress 技巧:强制 WordPress 直接升级

当添加,删除,升级 WordPress 插件或者直接升级 WordPress 的时候,有些用户的 WordPress 无法直接升级,总是提示让你输入 FTP/SFTP 帐号信息,这是因为 WordPress 是基于文件的所有者来判断的,如果你的服务器的用户名和文件的用户名不是一样的,那么 WordPress 就会让你通过 FTP/SFTP 来进行更新。

但是如果服务器的用户其实已经有权限对 FTP/SFTP 上传的文件进行读写的话,我们除了wp-config.php 定义 FTP/SFTP 信息之外,其实我们还可以强制 WordPress 直接升级。只需要在 wp-config.php 添加如下一行代码即可:


define('FS_METHOD','direct');